Befehle des Menübands überspringen
Zum Hauptinhalt wechseln
Lösungen von einem Team

Wenn Sie auf einer Microsoft Windows Vista-Maschine die Microsoft SQL Server 2005 Reporting Services, etwa zu Entwicklungszwecken, installiert haben, funktionieren diese möglicherweise nach der Installation von Windows Vista Service Pack 1 nicht mehr (so geschehen mit Windows Vista x64 Business Edition und SQL Server 2005 Developer Edition SP2). Die Installation des Windows Vista Service Pack 1 verlief fehlerfrei, aber Sie können keine SQL Server 2005 Reporting Services-Berichte mehr aufrufen.

Die Symptome können sein:

  • Aufrufe an http://localhost/reports enden mit einer Fehlermeldung über fehlgeschlagene Verbindungsversuche.
  • Aufrufe an http://localhost/reportserver enden mit einer HTTP 403.1-Fehlermeldung ("Verboten").
  • In den Reporting Services-Protokolldateien finden sich Meldungen über fehlgeschlagene Verbindungen zu 127.0.0.1:443, obwohl Sie HTTPS/SSL gar nicht verwenden.
  • Berichte können weder angezeigt noch hochgeladen oder verwaltet werden.

Die Lösung ist einfach, wenn man die Ursache erstmal gefunden hat: Dem virtuellen Verzeichnis ReportServer wurden durch die Installation von Windows Vista Service Pack 1 die Skriptausführungsrechte genommen. Zur Behebung des Problems können Sie so vorgehen:

  1. Starten Sie den Internetinformationsdienste-Manager.
  2. Öffnen Sie links in der Explorerleiste unterhalb des Computernamens Sites, Default Web Site (bzw. die Website, in die Sie die Reporting Services installiert haben), und markieren Sie darunter das virtuelle Verzeichnis ReportServer.
  3. Doppelklicken Sie im mittleren Bereich auf das Symbol Handlerzuordnungen.
  4. Wählen Sie im Aufgabenbereich rechts den Link Featureberechtigungen bearbeiten...
  5. Stellen Sie sicher, dass Lesen und Script aktiviert sind (Ausführen ist nicht notwendig). Die Installation von Windows Vista Service Pack 1 hat möglicherweise Script deaktiviert.
  6. Wählen Sie OK.
  7. Schließen Sie den Internetinformationsdienste-Manager.

Direkt danach sollten die Reporting Services wieder wie gewünscht funktionieren. Ein Neustart o.ä. ist nicht notwendig.

Voilà.